Coverage Issue

Major incident Data
2023-08-24 10:18 EST · 35 minutes

Updates

Resolved

The issue has been escalated and reported as now resolved.
Recovery is being observed.
If there are persisting issues, please raise with the customer care.

August 24, 2023 · 10:53 EST
Update

Our upstream provider has identified the issue and the service appears to be recovering.

August 24, 2023 · 10:39 EST
Investigating

We are receiving multiple incidents regarding coverage.
This is currently being investigated and escalated by our Roaming Partner.
IMSI affected: H1

August 24, 2023 · 10:18 EST

← Back