Global outage on Data connection

Minor incident Data SIM
2021-10-13 02:20 EST · 4 hours, 28 minutes, 4 seconds

Updates

Resolved

This incident has been resolved.

October 13, 2021 · 06:48 EST
De-escalate

The problem should be solved and all the SIM cards able to connect now. We are monitoring to ensure the stability of the network.

October 13, 2021 · 06:37 EST
Issue

Global outage: We’ve received information that one of our roaming partner has a worldwide fault. The issue started at 09:20 GMT+0. Unfortunately, we don’t have any estimated resolution time, our roaming partner is working hard to fix it.

October 13, 2021 · 02:56 EST

← Back