Service Degradation with 3G on IMSI 4

Minor incident Data
2022-03-30 03:32 EST · 5 days, 23 hours, 49 minutes

Updates

Resolved

The problem has been solved

April 5, 2022 · 03:22 EST
Issue

We are experiencing a service degradation with 3G on IMSI 4.

This problem might affect devices that are located in areas where the 4G signal is not optimal.

We are working to solve the issue and will keep you informed with the latest status.

March 30, 2022 · 03:33 EST

← Back